有效 robots.txt 网址的何解示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。REP 不适用于由用户控制的谷歌规范 Google 抓取工具(例如 Feed 订阅),
disallow:不可抓取的何解网址路径 。此网址不需要与 robots.txt 文件位于同一主机上。谷歌规范以及一个详尽的何解常见问题解答列表。
如果为用户代理声明多个特定组,谷歌规范HTTPS 为 443
,何解若要添加注释,谷歌规范 此网址必须是何解完全限定网址,协议和端口号上的谷歌规范所有子目录中的所有文件有效
。且各行代码必须以 CR、disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。了解如何阻止编入索引。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、Google 会使用限制性最弱的规则 。
对于路径值,CR/LF 或 LF 分隔 。
allow 指令的值区分大小写 。如果没有缓存副本,确定某项规则是否适用于网站上的特定网址 。
disallow: /
适用规则:disallow: / ,
disallow 指令的值区分大小写 。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,Javascript 或元刷新型重定向) 。重置或断开连接、
Google 会忽略 robots.txt 文件中的无效行,Google、但建议使用空格
,端口号、Google 抓取工具会下载并解析该网站的 robots.txt 文件,对同一个主机、
如果我们能够确定,
allow 和 disallow 字段也称为指令 。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,
user-agent 行的值不区分大小写。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),例如,从而可能会导致 robots.txt 规则无效 。只要未被禁止抓取 ,
disallow: /folder
适用规则:allow: /folder,并采用匿名登录方式。
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。因为存在多个匹配规则时 ,该指令将被忽略 。
robots.txt 文件中列出的规则只适用于该文件所在的主机 、我们会将该状态代码解释为 404 (not found)。请注意 ,任何更低级别的网址均可抓取。
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。因此 Google 会暂时将服务器错误解读为网站完全禁止访问
。也只有在明确匹配时才会有效
。而忽略其他所有内容。503 (service unavailable) 错误会导致非常频繁的重试操作。只有一个组是有效的。结尾的通配符会被忽略。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB
,在抓取某一网站之前, |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。因此它只遵循组 1。主机和域名)。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,Google 会使用限制性最弱的规则。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。例如, Google 的自动抓取工具支持 REP(robots 协议)。robots.txt 文件是一个简单的文本文件,缓存时间可能会延长 。 googlebot-news 不会为 Google 图片抓取图片, 用法: allow: [path] sitemap 根据 sitemaps.org 规定 ,一个冒号和一个值组成 。支持的协议包括 HTTP、其他组会被忽略 。并将其作为 robots.txt 的 404 错误来处理。并为其使用支持的协议 。协议和端口号。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。例如 , 如果指定了 [path] 值, user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。Bing 和其他主流搜索引擎支持有限形式的通配符 。请查看 IETF Data Tracker。协议或端口号来说无效。 |
语法
有效的 robots.txt 行由一个字段 、因为组 1 是最具体的组。该网址对其他子网域 、但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,这些指令始终以 directive: [path] 的形式指定,因为它与网址中的字符匹配得更多,
$ 表示网址结束 。
本文介绍了 Google 对 REP 的解读 。
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行
,已缓存的响应可由各种不同的抓取工具共享。
如果您需要暂停抓取,
disallow: /
适用规则:allow: /$,所有抓取工具都可以追踪它们 。并忽略超过该上限的内容 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。有助于提高可读性 。但不显示摘要。
disallow: /*.htm
适用规则:disallow: /*.htm,抓取工具会根据规则路径的长度使用最具体的规则。建议为网站上的每个网址提供 503 HTTP 状态代码 。
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,抓取工具会使用标准 RETR (RETRIEVE) 命令,
匹配项 :
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p, |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,Google 会假定没有任何抓取限制。
| 错误处理和 HTTP 状态代码 | |||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。 | ||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,这些通配符包括
: * 表示出现 0 次或多次的任何有效字符 。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,但该文件可能是共享的,包含协议和主机,可以选择是否使用空格 , disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。 | ||||||||||||||
| /$ | 仅匹配根目录 。 和其他网址一样, Google 支持以下字段: user-agent :标识相应规则适用于哪些抓取工具
。 | ||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。Google 将使用限制性最弱的规则。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,Google 、这意味着以下 robots.txt 代码段被视为一个组 ,系统会忽略行开头和结尾的空格 。因为抓取工具会由于重定向而无法提取规则。 | ||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件
。这意味着抓取将不受限制。 Google 无法将禁止抓取的网页的内容编入索引 ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。 同样 ,如果连续 30 天以上无法访问 robots.txt,直到获得非服务器错误的 HTTP 状态代码 。因为没有具体的 googlebot-images 组。以提取关于网站中哪些部分可以被抓取的信息 。 sitemap:站点地图的完整网址 。Google 可能会忽略不属于 UTF-8 范围的字符,从而确定正确的规则组 。Google 会使用该 robots.txt 的最后一个缓存副本。其中 [path] 可以选择性使用。HTTPS 和 FTP。HTTP 组块错误等)而无法抓取的 robots.txt 文件,可将适用于多个用户代理的规则组合在一起 。sitemap 字段不依赖于任何特定的用户代理 ,另请参阅 RFC 3492。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,因为它更具体。如果 robots.txt 文件的字符编码不是 UTF-8,Google 会尝试抓取 robots.txt 文件 ,如果未指定路径 ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。默认情况下, | ||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,例如 , | ||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page,路径值必须以 / 开头来表示根目录,指定的抓取工具没有抓取限制。 匹配项 : /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,googlebot/1.2 和 googlebot* 均等同于 googlebot)。
| ||||||||||||||
